summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Picht2019-05-21 06:50:39 +0200
committerMichael Picht2019-05-21 06:50:39 +0200
commitddae623d24321fbc0f517241e310ea36798c7701 (patch)
tree1ca834a8916637689cec8771812c742e91c8a2e9 /PKGBUILD
parent172aede807556df35273330bed5d2eb81b57e89b (diff)
downloadaur-ddae623d24321fbc0f517241e310ea36798c7701.tar.gz
release 1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22e718e3cacf..db70e969defe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Michael Picht <michael.picht@ussenterprise.de>
-pkgorg=github.com/mipimipi
+_pkgorg=github.com/mipimipi
pkgname=crema-git
_pkgname=crema
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Manage your custom Arch Linux repository"
arch=('any')
url="https://$pkgorg/$_pkgname"
license=('GPL3')
-source=("git://$pkgorg/$_pkgname.git")
+source=("git://$_pkgorg/$_pkgname.git")
md5sums=(SKIP)
depends=('aurutils')
-
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s.r%s.g%s" "$(git describe)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
cd "$srcdir/$_pkgname"