summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMGislv2023-09-21 01:47:13 +0200
committerMGislv2023-09-21 01:47:13 +0200
commit2cb0f7e1ec60526f652f8aebea853d9800890733 (patch)
tree594d06c38efca3462b729e5d84ef06a140dcb584 /PKGBUILD
parentd6d2238a3aad7f3501b8ef916b94055e7bd5d8b4 (diff)
downloadaur-crispy-doom-git.tar.gz
Update pkgver() to use git tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb5a506f11eb..b4bfcc0b0792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=crispy-doom-git
pkgdesc='Limit-removing enhanced-resolution Doom source port based on Chocolate Doom'
-pkgver=r8033.aeb61f3f
+pkgver=6.0.r122.ge69e50c9
pkgrel=1
arch=('x86_64_v3' 'x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
url='https://github.com/fabiangreffrath/crispy-doom'
@@ -19,7 +19,7 @@ md5sums=('SKIP')
pkgver() {
cd crispy-doom
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --match crispy-doom-* | sed 's/^crispy-doom-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {