summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorĽubomír Kučera2023-11-24 22:28:16 +0100
committerĽubomír Kučera2023-11-24 22:28:16 +0100
commit301f9781206c9d1583f5de786c9d8a7267228922 (patch)
treea4f8baa9160abf9beeb52d45ca64f40d97f26c83 /PKGBUILD
parent984ad024faae84e2e9a72c7d8ba58d99f7d78234 (diff)
downloadaur-301f9781206c9d1583f5de786c9d8a7267228922.tar.gz
Use system Zstandard
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2662bd4ff752..bf5e3b797324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=cronet
pkgver=119.0.6045.159
-pkgrel=3
+pkgrel=4
_manual_clone=0
pkgdesc="The networking stack of Chromium put into a library"
arch=('x86_64')
@@ -62,6 +62,7 @@ declare -gA _system_libs=(
[icu]=icu
[libevent]=libevent
[zlib]=minizip
+ [zstd]=zstd
)
declare -gA _system_make_libs=(
[jsoncpp]=jsoncpp
@@ -120,6 +121,7 @@ _unwanted_bundled_libs=(
third_party/vulkan-deps/spirv-tools/src
third_party/woff2
third_party/zlib
+ third_party/zstd
third_party/node
third_party/jdk
@@ -158,6 +160,9 @@ prepare() {
# Fixes `implicit instantiation of undefined template 'std::numeric_limits<unsigned long>'` error
patch -p0 -i ../fix-numeric_limits.patch
+ # Make building with system zstd possible
+ patch -Np1 -i ../chromium-patches-*/chromium-117-system-zstd.patch
+
# Remove bundled libraries for which we will use the system copies; this
# *should* do what the remove_bundled_libraries.py script does, with the
# added benefit of not having to list all the remaining libraries