summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2022-03-28 21:54:49 +0200
committerNicolas Iooss2022-03-28 21:54:49 +0200
commita2ef8b3f14aeaa123459b2fa92db647204df59a9 (patch)
tree0fff4826f8d4e112909393597a21c696f19bc4a2 /PKGBUILD
parent0d221f0063f206a8aa68a16439e568ebabf6889e (diff)
downloadaur-a2ef8b3f14aeaa123459b2fa92db647204df59a9.tar.gz
cronie-selinux 1.6.0-2 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45f50904737a..e1104f3ac257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname='cronie-selinux'
-pkgver=1.5.7
+pkgver=1.6.0
pkgrel=2
pkgdesc='Daemon that runs specified programs at scheduled times and related tools with SELinux support'
url='https://github.com/cronie-crond/cronie/'
@@ -22,13 +22,13 @@ provides=('cron' "${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
groups=('selinux')
source=("https://github.com/cronie-crond/cronie/releases/download/${pkgname/-selinux}-${pkgver}/${pkgname/-selinux}-${pkgver}.tar.gz"
- '0001-crontab-use-bold-colors.patch'
+ '0001-fix-range-entries.patch'
'80-cronie.hook'
'service'
'pam.d'
'deny')
-sha256sums=('538bcfaf2e986e5ae1edf6d1472a77ea8271d6a9005aee2497a9ed6e13320eb3'
- '2c9a2f386f23779907c468023538b195cd3e3c61fa16e19f036ee13a031f1c3a'
+sha256sums=('3f7cc263d21838b53a9943eb2a26b862059e2ae36c3f11789ac33cd6818e3628'
+ '29830d76a12992e1c74249d2aa577b8f6c52fc041beef5b4a066bed1004ddf84'
'f85e9a68bf3bf446f8a6167f068371c06afffe11ca71935d8ee5487b38b2c9db'
'ac3ff3c8a5ce1b6367b06877b4b12ff74e7f18a3c510fb9f80d6ea6b6321e3b1'
'00864268b491bab8c66400a4a4b4bf85f168a6e44e85676105e084940924090c'
@@ -38,10 +38,14 @@ backup=('etc/cron.deny'
'etc/cron.d/0hourly'
'etc/anacrontab')
-build() {
+prepare() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- patch -Np1 < ../0001-crontab-use-bold-colors.patch
+ patch -Np1 < ../0001-fix-range-entries.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
./configure \
--prefix=/usr \