summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcondy2022-07-22 04:54:55 +0800
committercondy2022-07-22 04:54:55 +0800
commit6c124ca45ebafca5d6b00adfbb788b61981d086d (patch)
treec882c93ba7ee271087feb3a7c9338eede056d328 /PKGBUILD
parentff555f3bac60c251e94a578f843fe70d454f71fa (diff)
downloadaur-6c124ca45ebafca5d6b00adfbb788b61981d086d.tar.gz
Change upstream to https://github/CrowCpp/Crow
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 808e41f74809..dbea2db48af6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
# Maintainer: condy chen <condy0919@gmail.com>
pkgname=crow-git
-pkgver=r351.16a0f6b
+pkgver=r1360.5f77b2bd
pkgrel=1
-pkgdesc='Crow is very fast and easy to use C++ micro web framework (inspired by Python Flask)'
+pkgdesc='A Fast and Easy to use microframework for the web'
arch=('any')
-url="https://github.com/ipkn/crow"
-license=('GPL')
-depends=('boost')
-makedepends=('git' 'cmake' 'make' 'boost' 'python')
+url="https://github.com/CrowCpp/Crow"
+license=('BSD')
+depends=('asio')
+makedepends=('git' 'cmake' 'make' 'python')
+optdepends=('openssl' 'zlib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-optoptions=('gperftools: Fast, multi-threaded malloc and nifty performance analysis tools')
-source=("${pkgname}"::'git+https://github.com/ipkn/crow.git')
+source=("${pkgname}"::'git+https://github.com/CrowCpp/Crow.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname}"
- mkdir build -p
- cd build
- cmake ..
- make
+ cd "$srcdir/${pkgname}"
+ cmake -S. -Bbuild -DCROW_BUILD_EXAMPLES=OFF -DCROW_BUILD_TESTS=OFF -DCROW_AMALGAMATE=ON -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/"
+ cmake --build build
}
package() {
- cd "$srcdir/${pkgname}"
- install -Dm644 "build/amalgamate/crow_all.h" "$pkgdir/usr/include/crow.h"
+ cd "$srcdir/${pkgname}"
+ cmake --install build
}