summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViech2021-05-24 13:17:06 +0200
committerViech2021-05-24 13:17:06 +0200
commitcc7de7b78d4204e7507cb12477791ae84f9c73c4 (patch)
treeb2dde9dd92a2da02b3d0f82aeef83e4fb2b6addc /PKGBUILD
parentf75a305d9a805bb4fcd56130af64764fb61447dc (diff)
downloadaur-cc7de7b78d4204e7507cb12477791ae84f9c73c4.tar.gz
Remove 'unvanquished' from the version string.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ec9395bd881..73930526be2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Viech <viech unvanquished net>
pkgname=crunch-unv-git
-pkgver=unvanquished.0.51.1.0.g559a1b0
+pkgver=0.52.0.r0.g9805bee
pkgrel=1
pkgdesc='DXTn texture compression tool. Modified version from Unvanquished Development.'
arch=('x86_64' 'i686')
@@ -10,10 +10,12 @@ license=('ZLIB')
makedepends=('git')
depends=('glibc')
source=("crunch::git+https://github.com/DaemonEngine/crunch.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/crunch/"
- git describe --tags --long | sed 's,[-/],.,g'
+ git describe --match 'unvanquished/*' --long \
+ | sed 's/^unvanquished\///;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -27,5 +29,3 @@ package() {
install -m755 "${srcdir}/crunch/crnlib/crunch" "${pkgdir}/usr/bin/crunch"
install -m644 "${srcdir}/crunch/license.txt" "${pkgdir}/usr/share/licenses/crunch/LICENSE"
}
-
-md5sums=('SKIP')