summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLev Levitsky2017-11-20 23:15:27 +0300
committerLev Levitsky2017-11-20 23:15:27 +0300
commit38164bd816e090fc546bff81be1b8a0c8cb4ac3c (patch)
treea75d523887414c798272d89ae10b370661aa0530 /PKGBUILD
downloadaur-38164bd816e090fc546bff81be1b8a0c8cb4ac3c.tar.gz
Submit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdfa329ec7f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Lev Levitsky <levlev at mail.ru>
+pkgname=crux-toolkit-bin
+pkgver=3.1
+pkgrel=1
+pkgdesc="A mass spectrometry analysis toolkit"
+arch=('x86_64' 'i686')
+url="http://crux.ms"
+license=('Apache')
+depends=('gcc-libs')
+provides=('crux-toolkit')
+source=("https://noble.gs.washington.edu/crux-downloads/crux-${pkgver}/crux-${pkgver}.Linux.${CARCH}.zip")
+noextract=()
+if [ "$CARCH" == 'i686' ]; then
+ md5sums=('7eae99e4d5c8fcd47916689622864dd4')
+else
+ md5sums=('0b2f29d9d41b64f8b5cd38bee3369666')
+fi
+
+package() {
+ install -D -t "${pkgdir}/usr/bin" "crux-${pkgver}.Linux.${CARCH}/bin/crux"
+}
+