summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2016-09-05 14:13:36 +0200
committerMichal Krenek (Mikos)2016-09-05 14:13:36 +0200
commitb222c351b166daff509cb240b22adb970a541e0c (patch)
treeefaa4e13d9f0193dd9b24f19064f213809cba1f4 /PKGBUILD
downloadaur-b222c351b166daff509cb240b22adb970a541e0c.tar.gz
Version 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7eaea03c47f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+pkgname=cryptboot
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Encrypted boot partition manager with UEFI Secure Boot support"
+arch=('any')
+url="https://github.com/xmikos/cryptboot"
+license=('GPL3')
+depends=('cryptsetup' 'grub' 'efibootmgr' 'efitools' 'sbsigntools')
+source=(https://github.com/xmikos/cryptboot/archive/v$pkgver.tar.gz)
+sha256sums=('1bd2d5547941c1bb15d220db7cc387f3e6c09beec2c59682384563c6f0ba49fe')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 cryptboot "$pkgdir/usr/bin/cryptboot"
+ install -Dm755 cryptboot-efikeys "$pkgdir/usr/bin/cryptboot-efikeys"
+ install -Dm644 cryptboot.conf "$pkgdir/etc/cryptboot.conf"
+}
+
+# vim:set ts=2 sw=2 et: