summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjerry732042016-01-21 02:06:44 +0800
committerjerry732042016-01-21 02:10:38 +0800
commitff41e4681de7e8ec611a14a98d4b4240f271ee4a (patch)
tree07caf91baf5fa45d7e36c0a72595a32e0dff0581 /PKGBUILD
parent7b34f553635ae76eded3e9f28a7289f65bf31519 (diff)
downloadaur-ff41e4681de7e8ec611a14a98d4b4240f271ee4a.tar.gz
Updated to 2.2.0-2. Remove unused file csmith.sh and update PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5abe4b4c0095..dc1cf6d9dc1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,14 @@
# Previous maintainer: spider-mario <spidermario@free.fr>
pkgname=csmith
pkgver=2.2.0
-pkgrel=1
-pkgdesc="Tool for stress-testing compilers, static analyzers, and other tools that process C code"
+pkgrel=2
+pkgdesc='Tool for stress-testing compilers, static analyzers, and other tools that process C code'
arch=('i686' 'x86_64')
-url="http://embed.cs.utah.edu/csmith/"
+url='http://embed.cs.utah.edu/csmith/'
license=('custom:BSD')
depends=('perl')
-source=(csmith.sh
- "https://embed.cs.utah.edu/csmith/${pkgname}-${pkgver}.tar.gz")
-md5sums=('75128bd5310cbc1c139b696da3b8e4d8'
- '05682b96f6607b00426d42718b9c2fd6')
+source=("https://embed.cs.utah.edu/csmith/${pkgname}-${pkgver}.tar.gz")
+md5sums=('05682b96f6607b00426d42718b9c2fd6')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -28,10 +26,6 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
-
- install --directory "${pkgdir}/etc/profile.d/"
- install ../../csmith.sh "${pkgdir}/etc/profile.d/"
-
install --directory "${pkgdir}/usr/share/licenses/${pkgname}/"
install COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}