summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2017-07-17 22:05:26 -0600
committerAinola2017-07-17 22:05:26 -0600
commit992fce3cbbb855e1196effa0ec1db93807ecdad9 (patch)
tree44eade38b10fbe051839cb3a136d1a0ea35ff94c /PKGBUILD
parent64bf9bd4f5da1a14944cb66b733a31446e5b6110 (diff)
downloadaur-992fce3cbbb855e1196effa0ec1db93807ecdad9.tar.gz
fix cmake flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec8a976b3e3c..e3a8f48235de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=csound
pkgver=6.09.1
-pkgrel=1
+pkgrel=2
pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
url="http://csound.github.io"
@@ -18,16 +18,13 @@ optdepends=('csound-doc: The Canonical Csound Reference Manual'
# Both Libextractor and Csound install /usr/bin/extractor
conflicts=('libextractor')
source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
- "Custom.cmake"
"python_install_dir.patch"
"csound.sh")
sha256sums=('d49735b4ed50f2818b577abcface45fe7f9b7fb49ccd898db030893cbcdfc738'
- '81c9473ad3142c658afe2e509f3ae597b5349bba07f95d4ba03f420188786e57'
'9c13a6d416294f073e481db934c6a816170af012d3b5b8707d8699deb29bee89'
'23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb')
prepare() {
- cp "$srcdir"/Custom.cmake "csound-${pkgver}"
# 6.09.1 tries to install python modules in the home dir.
# https://github.com/csound/csound/issues/828#issuecomment-315856126
patch -d "csound-$pkgver" -p1 < python_install_dir.patch
@@ -38,7 +35,11 @@ build() {
mkdir -p bld && cd bld
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DJAVA_MODULE_INSTALL_DIR=/usr/lib/csound/java \
+ -DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages \
+ -DLUA_MODULE_INSTALL_DIR=/usr/lib/lua/5.1 \
+ -DDPD_MODULE_INSTALL_DIR=/usr/lib/pd/extra
make
}