summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2017-02-25 13:24:48 -0700
committerAinola2017-02-25 13:24:48 -0700
commitc0dae74ff1e1a65d2a7ac509c679314f7104c4c1 (patch)
treefbbdb6d61443447af888ab961790b6bca3edb751 /PKGBUILD
parent7b15757d79d13ce1b319db7f1a490baac31db5e9 (diff)
downloadaur-c0dae74ff1e1a65d2a7ac509c679314f7104c4c1.tar.gz
add python dependency and cmake build support for python opcodes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1088f05b5529..ca25da1037e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,11 @@ pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
url="http://csound.github.io"
license=('LGPL')
-depends=('fltk' 'fluidsynth' 'liblo' 'portaudio' 'portmidi' 'tk' 'curl' 'stk' 'luajit')
+depends=('fltk' 'fluidsynth' 'liblo' 'portaudio' 'portmidi' 'tk' 'curl' 'stk' 'luajit' 'python2')
makedepends=('pd' 'cmake' 'gmm' 'swig' 'java-environment' 'dssi' 'boost' 'luajit' 'eigen')
optdepends=('csound-doc: The Canonical Csound Reference Manual'
'csoundqt: Qt frontend'
'java-environment: Java Wrapper'
- 'python2: csnd6 python bindings'
'vim-csound: Syntax Highlighting and Bindings for Vim')
source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
"Custom.cmake"
@@ -30,7 +29,9 @@ prepare() {
build() {
cd "csound-${pkgver}"
mkdir -p bld && cd bld
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so
make
}