summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2015-07-18 17:24:37 -0600
committerAinola2015-07-18 17:24:37 -0600
commite24259424d10d407e00670ad04c3a216fcd2563f (patch)
tree8f7f4c24fd4b24c2451f41f063221e3f24abaf35 /PKGBUILD
parent1178530c814241b5bedc87d2f1b34af989a59285 (diff)
downloadaur-e24259424d10d407e00670ad04c3a216fcd2563f.tar.gz
move source from sourceforge to github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f6573ae7662..db682f55cb52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Ainola <opp310@alh.rqh> (ROT13 this.)
-# Contributor: speps <speps at aur dot archlinux dot org>
-# Contributor: Bernardo Barros <bernardobarros@gmail.com>
+# Maintainer: Ainola
+# Contributor: speps
+# Contributor: Bernardo Barros
pkgname=csound
-pkgver=6.05
+pkgver=6.05.0
pkgrel=1
pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
@@ -15,13 +15,13 @@ optdepends=('csoundqt: Qt frontend'
'vim-csound: Syntax Highlighting and Bindings for Vim'
'java-environment: Java Wrapper'
'csound-doc: The Canonical Csound Reference Manual')
-source=("http://downloads.sourceforge.net/project/csound/csound${pkgver:0:1}/Csound${pkgver:0:4}/Csound${pkgver}.tar.gz"
+source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
"csound.sh")
-sha256sums=('0d0ab4c1804265f4947e07c5e41ee72bc1a122b873bd77b9e7179f4c4db43a28'
+sha256sums=('2384cbc82fe37b70192c87977b52c55b336731ecbfd3be1d8d30c7223815d7b9'
'23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb')
prepare() {
- cd "Csound${pkgver}"
+ cd "csound-${pkgver}"
# install modules to proper paths
sed -i '/^set.*MODULE_INSTALL_DIR/d' CMakeLists.txt
@@ -30,7 +30,7 @@ prepare() {
}
build() {
- cd "Csound${pkgver}"
+ cd "csound-${pkgver}"
mkdir -p bld && cd bld
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages \
@@ -41,7 +41,7 @@ build() {
}
package() {
- cd "Csound${pkgver}/bld"
+ cd "csound-${pkgver}/bld"
make DESTDIR="$pkgdir/" install
# export vars in profile.d