summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrainDamage2017-01-28 15:05:22 +0100
committerBrainDamage2017-01-28 15:05:22 +0100
commitfc2f1dee4d7809ac362e87dacd9ec34263fc3a0d (patch)
tree50dbe6a72194e6ba74b1127b284e4e0cc8a49955 /PKGBUILD
downloadaur-fc2f1dee4d7809ac362e87dacd9ec34263fc3a0d.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8efc79758acd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: BrainDamage <braindamage springlobby.info>
+
+pkgname=cspice
+pkgver="N0065"
+pkgrel=1
+pkgdesc="A comprehensive toolkit and api to design, simulate and analyse space missions"
+arch=("x86_64")
+url="https://naif.jpl.nasa.gov/naif/aboutspice.html"
+depends=("glibc")
+makedepends=("tcsh")
+source=("http://naif.jpl.nasa.gov/pub/naif/toolkit//C/PC_Linux_GCC_64bit/packages/cspice.tar.Z")
+sha1sums=('335a16141e3d4f5d2e596838285fc9f918c2f328')
+
+
+build() {
+ cd "cspice"
+ ./makeall.csh
+}
+
+package() {
+ cd "cspice"
+ mkdir -p "$pkgdir/usr"
+ mkdir -p "$pkgdir/usr/share/doc"
+
+ cp -R data "$pkgdir/usr/share/cspice"
+ cp -R doc "$pkgdir/usr/share/doc/cspice"
+ cp -R exe "$pkgdir/usr/bin"
+ cp -R include "$pkgdir/usr/"
+ cp -R lib "$pkgdir/usr/"
+}