summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Pałubicki2019-02-28 23:26:41 +0100
committerMichał Pałubicki2019-02-28 23:26:41 +0100
commit6018c0fbff7610ffbd6cdb282391472564983f0e (patch)
treed0834fb995b9b996f18aa5d7d827776110563d81 /PKGBUILD
parent9fa16b7b0ccc0cd7e8138b7e237d4fec33e518e0 (diff)
downloadaur-6018c0fbff7610ffbd6cdb282391472564983f0e.tar.gz
Added docs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdf12c70610b..f69c542c5eac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=csvkit
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="A suite of utilities for converting to and working with CSV."
arch=("any")
url="http://csvkit.readthedocs.org"
@@ -23,13 +23,21 @@ depends=(
optdepends=(
'ipython: nicer command-line for csvpy utility'
)
-makedepends=("python-setuptools")
+makedepends=(
+ 'python-setuptools'
+ 'python-sphinx>=1.2.2'
+ 'python-sphinx_rtd_theme>=0.1.6'
+ )
source=("https://github.com/wireservice/csvkit/archive/${pkgver}.tar.gz")
sha256sums=('4ca64988a648c845ad2f02a19d5736c3a2650a44b1dd8952b97b528c7f3e2a97')
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+
+ python setup.py build_sphinx
+ mkdir -p "$pkgdir/usr/share/doc"
+ cp -rv "$srcdir/$pkgname-$pkgver/build/sphinx/html" "$pkgdir/usr/share/doc/$pkgname"
}
check() {