summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilosD2015-07-05 12:03:39 +0200
committerMilosD2015-07-05 12:03:39 +0200
commite7734b8e98072dbd63614c44de5067b13b3f56f6 (patch)
treea91af5b62f8ea0eec4b2a57958288033537e3fb6 /PKGBUILD
parent1c09f158958f5367ec68c1f5cc027a71286f1418 (diff)
downloadaur-e7734b8e98072dbd63614c44de5067b13b3f56f6.tar.gz
Update to 2.0 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30d068434aea..5ca7fb99bf4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
-#Maintainer : gls < ghostlovescorebg at gmail dot com >
+# Maintainer : gls < ghostlovescorebg at gmail dot com >
pkgname=csync2
-pkgver=1.34
-pkgrel=4
+pkgver=2.0
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Asynchronous cluster syncronisation tool based on librsync and inspired by Unison"
url="http://oss.linbit.com/csync2/"
license=('GPL')
depends=(librsync sqlite2 libgcrypt libgpg-error gnutls libtasn1)
-source=(http://oss.linbit.com/csync2/$pkgname-$pkgver.tar.gz)
-backup=(etc/csync2.cfg)
-md5sums=('efc8a3548996b79cef2ad76af5e93cd8')
+source=(http://oss.linbit.com/csync2/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('11cb37380fb185bce0c22b804fec9b01c385d9d83cc528cfd48d748453834fa2')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -e 's/\-1.7//g' -i ./autogen.sh
+ cd ${srcdir}/${pkgname}-${pkgver}
- #AM_PATH_LIBGNUTLS does not exist any more
sed -ie 's/.*AM_PATH_LIBGNUTLS.*/PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.2.0], have_gnutls=yes, have_gnutls=no)/g' configure.ac
sed -ie 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac
- ./autogen.sh
- ./configure --prefix=/usr --bindir=/bin
+ ./configure --prefix=/usr --bindir=/bin --disable-gnutls
+
+ sed -ie 's/aclocal-1.14/aclocal-1.15/g' Makefile
+ sed -ie 's/automake-1.14/automake-1.15/g' Makefile
+
make
- # By default, csync2 tries to install binary to /usr/bin/sbin.
- # This line changes Makefile and tells compiler to put binary in /usr/bin.
+}
+
+package() {
+
+ cd ${srcdir}/${pkgname}-${pkgver}
sed -ie 's/sbindir\ =\ \${exec_prefix}\/sbin/sbindir\ =\ \${exec_prefix}\/bin/g' Makefile
+ make DESTDIR=${pkgdir} install
+ find ${pkgdir} -name '*.la' -exec rm {} \;
- make DESTDIR="$pkgdir" install
- find "$pkgdir" -name '*.la' -exec rm {} \;
}
# vim:set ts=2 sw=2 et: