summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:11:10 +0900
committerDaichi Shinozaki2015-06-09 18:11:10 +0900
commit5985a71b5e06ff83fa909e792b373df096efc877 (patch)
treec46409f9bfed65018877f6bef9bedac8e3c1690e /PKGBUILD
downloadaur-5985a71b5e06ff83fa909e792b373df096efc877.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7fdbb33a5b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+
+pkgname=ctags_as3_haxe
+pkgver=5.8
+pkgrel=2
+pkgdesc="Generates an index file of language objects found in source files, with patch for as3 and haxe"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+provides=('ctags')
+conflicts=('ctags')
+url="http://www.dafishinsea.com/blog/2010/01/21/getting-ctags-to-work-with-actionscript-and-haxe/"
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname%%_*}/${pkgname%%_*}-${pkgver}.tar.gz"
+ 'http://www.dafishinsea.com/downloads/ctags_as3_haxe_patched_files.tar.gz')
+md5sums=('c00f82ecdcc357434731913e5b48630d'
+ 'faa6108de15b2bae2feac521b5e5b7f7')
+
+build() {
+ cd ${srcdir}/${pkgname%%_*}-${pkgver}
+ install -m644 $srcdir/ctags_as3_haxe_patched_files/* .
+ ./configure --prefix=/usr \
+ --disable-external-sort
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname%%_*}-${pkgver}
+ make prefix=${pkgdir}/usr install
+}