summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmelia2021-09-08 21:29:42 -0400
committerAmelia2021-09-08 21:29:42 -0400
commit0ef8d3900668e0bcd27c4993cf8a88f0916f7c44 (patch)
tree8cdd393dab516d58765b42beebd9158db65c38f3 /PKGBUILD
parent21368e77cd5d94a03dbb16b8bc4271e266574a80 (diff)
downloadaur-ctf-recon-utils.tar.gz
Added an official source rather than using git clone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faa7451111fa..9e07b104e5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
# Maintainer: Amelia (AmeliaYeah@aur.archlinux.org)
pkgname='ctf-recon-utils'
-pkgver=1.0
-pkgrel=1
-pkgdesc="Some scripts that make CTF Reconnaisance alot more straightforward."
+pkgver="1.0.0"
+pkgrel=1.1
+pkgdesc="Some scripts that make CTF Reconnaisance a bit more straightforward."
arch=('x86_64')
url="https://github.com/AmeliaYeah/ctf-recon-utils"
license=('GPL')
-depends=('ffuf' 'gobuster' 'nikto' 'curl' 'nmap' 'git' 'python3' 'python-pip')
+depends=('ffuf' 'gobuster' 'nikto' 'curl' 'nmap' 'python3' 'python-pip')
optdepends=('libnotify')
-
-prepare() {
- echo "Cloning github repository..."
- git clone "$url" "$srcdir/ctf-recon"
-}
+source=("https://github.com/AmeliaYeah/ctf-recon-utils/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('SKIP')
package() {
echo "Making the package directories..."
@@ -23,14 +20,10 @@ package() {
export base_dir
echo "Moving into the cloned repository..."
- git_repo="$srcdir/ctf-recon"
+ git_repo="$srcdir/ctf-recon-utils-${pkgver}"
cd "$git_repo"
echo "Running the install script..."
chmod +x ./install.sh
./install.sh
-
- echo "Cleaning out the repository..."
- cd "$srcdir"
- rm -rf "$git_repo"
}