summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmelia2021-09-06 16:34:26 -0400
committerAmelia2021-09-06 16:34:26 -0400
commit21368e77cd5d94a03dbb16b8bc4271e266574a80 (patch)
tree9d01187d4c62a1b2b7ddffa53840d9115a46e65a /PKGBUILD
downloadaur-21368e77cd5d94a03dbb16b8bc4271e266574a80.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa7451111fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Amelia (AmeliaYeah@aur.archlinux.org)
+pkgname='ctf-recon-utils'
+pkgver=1.0
+pkgrel=1
+pkgdesc="Some scripts that make CTF Reconnaisance alot more straightforward."
+arch=('x86_64')
+url="https://github.com/AmeliaYeah/ctf-recon-utils"
+license=('GPL')
+depends=('ffuf' 'gobuster' 'nikto' 'curl' 'nmap' 'git' 'python3' 'python-pip')
+optdepends=('libnotify')
+
+prepare() {
+ echo "Cloning github repository..."
+ git clone "$url" "$srcdir/ctf-recon"
+}
+
+package() {
+ echo "Making the package directories..."
+ mkdir -p "$pkgdir/usr"
+
+ echo "Setting the base directory for the installation script..."
+ base_dir="$pkgdir"
+ export base_dir
+
+ echo "Moving into the cloned repository..."
+ git_repo="$srcdir/ctf-recon"
+ cd "$git_repo"
+
+ echo "Running the install script..."
+ chmod +x ./install.sh
+ ./install.sh
+
+ echo "Cleaning out the repository..."
+ cd "$srcdir"
+ rm -rf "$git_repo"
+}