summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWeitian Leung2018-10-14 16:44:09 +0800
committerWeitian Leung2018-10-14 16:44:09 +0800
commitc1fa3359091b32f7de84ef32559f1b8858a2d107 (patch)
tree971d693fa63c7cda765ae42ca95d5072636d2ced /PKGBUILD
parent8d74386145ed097f243cbd3624f48fa929709884 (diff)
downloadaur-cu-notify-git.tar.gz
Changes the way autostart
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c68a78de16f1..ac45dc20cfba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Weitian Leung <weitianleung[at]gmail[dot]com>
pkgname=cu-notify-git
-pkgver=r9
+pkgver=r10
pkgrel=1
pkgdesc="Auto check ArchLinux package updates, popup notification if new updates available"
arch=(any)
@@ -11,6 +11,7 @@ depends=('python-pyqt5' 'pacman-contrib')
makedepends=('git')
source=("$pkgname::git+https://github.com/timxx/cu-notify.git")
md5sums=('SKIP')
+install=${pkgname}.install
pkgver() {
cd "$srcdir/$pkgname"
@@ -19,9 +20,6 @@ pkgver() {
package() {
cd $srcdir/$pkgname
- install -d "$pkgdir/usr/bin"
- cp cu-notify "$pkgdir/usr/bin"
-
- install -d "$pkgdir/etc/xdg/autostart"
- cp cu-notify-autostart.desktop "$pkgdir/etc/xdg/autostart"
+ install -Dm755 "cu-notify" "$pkgdir/usr/bin/cu-notify"
+ install -Dm644 "cu-notify.service" "$pkgdir/usr/lib/systemd/user/cu-notify.service"
}