summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWeitian Leung2016-04-18 22:08:09 +0800
committerWeitian Leung2016-04-18 22:08:09 +0800
commit720ced86b8d662744cfa6778d975825ed711c472 (patch)
tree3ec2d2eeab695fed75b6e20960f3e4c975258695 /PKGBUILD
downloadaur-720ced86b8d662744cfa6778d975825ed711c472.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc7525350df6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Weitian Leung <weitianleung[at]gmail[dot]com>
+
+pkgname=cu-notify-git
+pkgver=r2
+pkgrel=1
+pkgdesc="Auto check ArchLinux package updates, popup notification if new updates available"
+arch=(any)
+url="https://github.com/timxx/cu-notify"
+license=('MIT')
+depends=('libnotify' 'pacman')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/timxx/cu-notify.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd $srcdir/$pkgname
+ install -d "$pkgdir/usr/bin"
+ cp cu-notify "$pkgdir/usr/bin"
+
+ install -d "$pkgdir/etc/xdg/autostart"
+ cp cu-notify-autostart.desktop "$pkgdir/etc/xdg/autostart"
+}