summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-12-27 16:51:05 +0100
committerAlexandre Bouvier2022-12-27 16:51:05 +0100
commit0177a8bdf2fb145a1c36c29c17d17813418deb51 (patch)
tree890ab9f7273066f55df697492c85d710b5f0550b /PKGBUILD
parent0ca110e981020df129a9122c76e87999b51b777f (diff)
downloadaur-0177a8bdf2fb145a1c36c29c17d17813418deb51.tar.gz
update to 0.2.r1420.gdbc6033
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2eb6d38a99a3..cd6f725ff045 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Zion Nimchuk <zionnimchuk@gmail.com>
_pkgname=cubeb
pkgname=$_pkgname-git
-pkgver=0.2.r1395.g28c8aa4
+pkgver=0.2.r1420.gdbc6033
pkgrel=1
pkgdesc="Cross platform audio library"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
@@ -26,6 +26,11 @@ pkgver() {
git describe --long --tags | sed 's/^cubeb-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ # https://github.com/mozilla/cubeb/issues/736
+ sed -i '/cubeb_add_test(logging)/d' $_pkgname/CMakeLists.txt
+}
+
build() {
cmake -S $_pkgname -B build \
-DBUILD_SHARED_LIBS=ON \