summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author910JQK2016-02-14 22:04:02 +0800
committer910JQK2016-02-14 22:04:02 +0800
commite2eb2d0c88568f7883207b4bd0342dc3b66234b0 (patch)
treed77ad38082b1b62f255e4d0daf1b818e6a35414f /PKGBUILD
downloadaur-e2eb2d0c88568f7883207b4bd0342dc3b66234b0.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c36633cd951d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: 910JQK <v910JQK@gmail.com>
+_pkgname=cubway-jslib-simplejs
+pkgname=$_pkgname-git
+pkgver=r30.a081568
+pkgrel=1
+pkgdesc='Simple DOM operation library.'
+arch=('any')
+url='https://github.com/SubwayDesktop/simple.js/'
+makedepends=('coreutils')
+provides=('cubway-jslib-simplejs')
+source=('cubway-jslib-simplejs::git+https://github.com/SubwayDesktop/simple.js.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -m755 -d "${pkgdir}/opt/Subway/simple.js"
+ install -m755 simple.js "${pkgdir}/opt/Subway/simple.js/"
+}