summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Nicoulaud2018-12-07 20:08:51 +0100
committerJulien Nicoulaud2018-12-07 20:08:51 +0100
commita5b82132579cc8a95cfa44650321ac4382d620ab (patch)
tree1f4bab2952570fc5a521efaf17e245a9bed7f77e /PKGBUILD
downloadaur-a5b82132579cc8a95cfa44650321ac4382d620ab.tar.gz
1.0.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b6f112729e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+pkgname=cuppa
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Comprehensive Upstream Provider Polling Assistant."
+arch=('i686' 'x86_64')
+url="https://github.com/DataDrake/cuppa"
+license=(MIT)
+makedepends=('go-pie' 'make')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/DataDrake/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('4128f979856d2c16a07b0f5a103a1ebfb492c28931705257e2ed1918444bc26d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}