summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen2019-07-28 20:18:59 +0200
committerBen2019-07-28 20:21:59 +0200
commit714dd1dd69f02ac34f3107be13dc678b3b04da74 (patch)
treecacdfcd65eba3c5e42ad6fe10001dac1eeac97c5 /PKGBUILD
parent9ea4d1c1ee8ac4b22989a0e90235addfb024083f (diff)
downloadaur-714dd1dd69f02ac34f3107be13dc678b3b04da74.tar.gz
Patch to replace strcpy with memcpy for GCC 8.1+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fad22136511..32c9ef2dbfd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=cups-bjnp
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='CUPS back-end for the canon printers using the proprietary USB over IP BJNP protocol'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/cups-bjnp/'
@@ -17,6 +17,9 @@ sha256sums=('95b5940daf6ee46120efef9c05048ade9bb855de36280c140895f9672b2946c0')
build() {
cd cups-bjnp-${pkgver}
+ # Patch for https://gcc.gnu.org/onlinedocs/gcc-8.1.0/gcc/Warning-Options.html#index-Wstringop_002dtruncation
+ sed -i 's/strncpy/memcpy/' bjnp-commands.c
+
./configure --prefix='/usr'
make
}