summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKristian Gunstone2016-03-11 14:51:25 +0100
committerKristian Gunstone2016-03-11 14:52:31 +0100
commit7e7c6e31ba49a9251e0c98ccc6e007ab9cd9ca72 (patch)
tree956e3e1686678731286e00c448142c4f8af5f26b /PKGBUILD
downloadaur-7e7c6e31ba49a9251e0c98ccc6e007ab9cd9ca72.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..150bc34a2997
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Kristian Gunstone <kristian.gunstone.butnotthispart@pean.northis.org>
+# Contributor: Jan-Tarek Butt <tarek@ring0.de>
+# This PKGBUILD is based on the 'cura-old' PKGBUILD maintained by Jan-Tarek.
+# A specific version of CuraEngine is bundled with Aleph's Cura, and so it also
+# comes with this package.
+pkgname=cura-aleph-bin
+pkgver=18.03
+pkgrel=1
+pkgdesc="A full 3D printing solution aimed at RepRaps and the Ultimaker.
+This is the Aleph Objects fork, specialized for the Lulzbot series of 3D printers."
+arch=('i686' 'x86_64')
+url="https://www.lulzbot.com/cura"
+license=('AGPL3')
+depends=('bash'
+ 'python2'
+ 'wxpython'
+ 'python2-opengl'
+ 'python2-pyserial'
+ 'python2-numpy'
+ 'python2-power-git')
+provides=('cura')
+conflicts=('cura'
+ 'cura-bin'
+ 'cura-git'
+ 'cura-old'
+ 'cura-not-so-old')
+
+_aleph_ver_major=$(echo "$pkgver" | cut -d "." -f 1)
+_aleph_url_root="http://download.lulzbot.com/Software/Cura/Packages/Cura_${_aleph_ver_major}"
+
+if [ "$CARCH" == x86_64 ]; then
+ source+=(${_aleph_url_root}/cura_${pkgver}-8bed_amd64.deb)
+ sha1sums+=('458528f3e1ea5033d0a2efdc10c9108184791a15')
+elif [ "$CARCH" == i686 ]; then
+ source+=(${_aleph_url_root}/cura_${pkgver}-8bed_i386.deb)
+ sha1sums+=('fd6ed10d0b4fea59129be2596c044021ca94c648')
+fi
+
+source+=(arch_aleph_patch.diff)
+sha1sums+=('ba7a71da6f433e57e4cb67b9a295d4c249518b6e')
+
+prepare()
+{
+ # Unpack the tarball containing the 'usr/' directory,
+ # where all the essentials reside within the debian package
+ tar zxf "${srcdir}/data.tar".gz -C "${srcdir}"
+
+ # remove python-power since we have it in the deps:
+ rm -rv "${srcdir}"/usr/share/cura/power/
+ rm -rv "${srcdir}"/usr/share/cura/Cura/util/Power
+
+ # Apply the patchset, which mainly changes any ambiguous references
+ # to 'python' to 'python2' (as arch uses python3 by default)
+ patch -d "${srcdir}" -p1 < ../arch_aleph_patch.diff
+}
+
+package()
+{
+ cp -r "${srcdir}"/usr "${pkgdir}"/usr
+}