summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin McCormack2020-06-26 01:56:58 -0400
committerKevin McCormack2020-06-26 01:56:58 -0400
commitee920a436413b87bd10c280234fa974bc2e0ca75 (patch)
tree2e7b26b1c566d482243d626dbd5797b31fc88f32 /PKGBUILD
parent9397c4f210b191c48981046dce3e5c2cb0be43b0 (diff)
downloadaur-ee920a436413b87bd10c280234fa974bc2e0ca75.tar.gz
Update for building in clean chroot
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1158a2c72af..b4ff97013835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://gitlab.com/lulzbot3d/cura-le/curabuild-lulzbot/
pkgname=cura-lulzbot
pkgver=3.6.21
-pkgrel=5
+pkgrel=6
pkgdesc='Cura LulzBot Edition for LulzBot 3D Printers by Aleph Objects, Inc.'
arch=('x86_64')
url='https://www.lulzbot.com/cura'
@@ -29,7 +29,7 @@ depends=('cython'
'qt5-graphicaleffects'
'qt5-quickcontrols'
'qt5-quickcontrols2'
- 'qt5-svg')
+ 'qt5-svg')
makedepends=('cmake'
'git'
'python-sip'
@@ -57,13 +57,13 @@ build() {
mkdir -p curabuild-lulzbot/build
cd curabuild-lulzbot/build
sed -i 's/DCURA_ENGINE_VERSION=${CURA_VERSION}/DCURA_ENGINE_VERSION=${CURA_VERSION} -DENABLE_OPENMP=OFF/' ../CMakeLists.txt
- sed -i '33,34d' ../setup_linux.py.in #remove missing paths from using system python
- sed -i '57,58d' ../setup_linux.py.in #remove missing qt plugins when using system version
- sed -i 's/get_commit_hash("Savitar", cmake_binary_dir)/"4.1.0"/' ../scripts/cura_version.py #fake hash when using system libsavitar
+ sed -i '33,34 s/^/#pkgbuild /' ../setup_linux.py.in # Disable missing paths from using system python
+ sed -i '57,60 s/^/#pkgbuild /' ../setup_linux.py.in # Disable missing qt plugins when using system version
+ sed -i 's/get_commit_hash("Savitar", cmake_binary_dir)/"4.1.0"/' ../scripts/cura_version.py # Fake hash when using system libsavitar
sed -i 's/6a4ffb2f90ef7bbd3f20f2a1db4948630ad37dc8/v3.11.0/' ../CMakeLists.txt # Protobuf v3.7.0
- sed -i '1216,1233d' ../CMakeLists.txt # Remove external cx_Freeze build
+ sed -i '1224,1241 s/^/#pkgbuild /' ../CMakeLists.txt # Disable external cx_Freeze build
cmake -DTAG_OR_BRANCH=master ../ \
-DBUILD_PYTHON=OFF \
@@ -112,3 +112,13 @@ package() {
## Update .SRCINFO
# makepkg --printsrcinfo | tee .SRCINFO
+
+##
+# Build in a clean chroot
+# https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot
+#
+# We need to install libffi6 and python-numpy-stl from AUR.
+# We also need to manually install openblas to avoid a conflict with blas.
+#
+# Ex.
+# extra-x86_64-build -- -c -I ~/builds/libffi6/libffi6-3.2.1-1-x86_64.pkg.tar.xz -I ~/builds/python-numpy-stl/python-numpy-stl-2.10.1-1-any.pkg.tar.xz -I /var/cache/pacman/pkg/openblas-0.3.10-1-x86_64.pkg.tar.zst