summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2017-01-24 14:20:38 -0500
committerAdam Goldsmith2017-01-24 14:20:38 -0500
commit24d18d73262f6da517a03ee5800bd634c67b653d (patch)
tree69a1ae7eeb0f546230d4596bf50e4e97095c37a7 /PKGBUILD
downloadaur-24d18d73262f6da517a03ee5800bd634c67b653d.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4c24bd22b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=cura-plugin-orientation-git
+_pkgname=cura-plugin-orientation
+pkgver=r112.05c6a03
+pkgrel=1
+pkgdesc="A Cura plugin that allows you to quickly calculate and apply the best printable orientation."
+arch=('any')
+license=('GPL3')
+url="https://github.com/nallath/CuraOrientationPlugin"
+depends=('python' 'cura' 'python-zeroconf' 'python-numpy')
+makedepends=('git')
+source=("$_pkgname::git+https://github.com/nallath/CuraOrientationPlugin.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p "$_pkgname"/build
+ cd "$_pkgname"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: