summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-05-04 19:47:50 -0500
committerLuis Martinez2022-05-04 19:47:50 -0500
commit678599f3da649ccbcf24c644029d7f66204f9118 (patch)
tree7a6d7b4b49a1ed4779b82d25af95608eeb1503bd /PKGBUILD
parent59553612b9434ee71ea1efaf197dd9ce51ae214b (diff)
downloadaur-678599f3da649ccbcf24c644029d7f66204f9118.tar.gz
package cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 41 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11332ee71f8c..5efaf2a7c049 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,63 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Vincent Grande <shoober420@gmail.com>
# Contributor: Dave Reisner <dreisner@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+## GPG key: https://daniel.haxx.se/mykey.asc
+
pkgname=curl-git
-pkgver=7.72.0
+pkgver=7.83.0.r29.g6db4ef124
pkgrel=1
pkgdesc="An URL retrieval utility and library"
arch=('x86_64')
-url="https://curl.haxx.se"
+url="https://github.com/curl/curl"
license=('MIT')
-depends=('ca-certificates' 'krb5' 'libssh2' 'libssh2.so' 'openssl' 'zlib'
- 'libpsl' 'libpsl.so' 'libnghttp2' 'libidn2' 'zstd')
-provides=('libcurl.so' curl)
-conflicts=(curl)
-source=("git+https://github.com/curl/curl")
-sha512sums=('SKIP')
+depends=(
+ 'ca-certificates' 'brotli' 'libbrotlidec.so' 'libgssapi_krb5.so'
+ 'krb5' 'libidn2' 'libidn2.so' 'libnghttp2' 'libpsl' 'libpsl.so'
+ 'libssh2' 'libssh2.so' 'openssl' 'zlib' 'zstd' 'libzstd.so')
+makedepends=('git')
+provides=('libcurl.so' 'curl')
+conflicts=('curl')
+source=("$pkgname::git+$url?signed")
+sha256sums=('SKIP')
+validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') ## Daniel Stenburg
pkgver() {
- cd curl
- git describe --tags | sed 's/-/+/g'
+ git -C "$pkgname" describe --long --tags | sed 's/^curl-//;s/_/./g;s/-/.r/;s/-/./'
}
build() {
- cd curl
-
- ./buildconf
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --disable-ldap \
- --disable-ldaps \
- --disable-manual \
- --enable-ipv6 \
- --enable-versioned-symbols \
- --enable-threaded-resolver \
- --with-gssapi \
- --with-libssh2 \
- --with-random=/dev/urandom \
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
-
- make
+ cd "$pkgname"
+
+ ./buildconf
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-ldap \
+ --disable-ldaps \
+ --disable-manual \
+ --enable-ipv6 \
+ --enable-versioned-symbols \
+ --enable-threaded-resolver \
+ --with-gssapi \
+ --with-libssh2 \
+ --with-openssl \
+ --with-random=/dev/urandom \
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+
+ make
}
package() {
- cd curl
+ cd "$pkgname"
- make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" install -C scripts
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install -C scripts
- # license
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
+ # license
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}