summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-09-19 18:27:15 -0400
committerVincent Grande2020-09-19 18:27:15 -0400
commitda42ceb859fed1d6801bc20e6657e3f8142386c3 (patch)
tree4abaa3fd8a74e0e1c661e2f7358b2637e2e4715f /PKGBUILD
parent3251d2670c13e48966638c8129437923ddfa5874 (diff)
downloadaur-da42ceb859fed1d6801bc20e6657e3f8142386c3.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 22 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd6cea4de052..ed4da14c69ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,38 @@
-# Maintainer: Dave Reisner <d@falconindy.com>
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=curl-git
-pkgver=7.56.0.55.g4440b6ad5
+pkgver=7.72.0
pkgrel=1
-pkgdesc="A URL retrieval utility and library"
-arch=('i686' 'x86_64')
-url="https://curl.haxx.se/"
+pkgdesc="An URL retrieval utility and library"
+arch=('x86_64')
+url="https://curl.haxx.se"
license=('MIT')
-depends=('ca-certificates' 'krb5' 'libssh2' 'openssl' 'zlib' 'libpsl' 'libnghttp2')
-makedepends=('git')
-provides=("curl=$pkgver" 'libcurl.so')
-conflicts=('curl')
-options=('!libtool')
-source=('git://github.com/curl/curl.git')
-md5sums=('SKIP')
-
-pkgver() {
- cd curl
-
- git describe | sed 's/curl-//; s/[_-]/./g'
-}
+depends=('ca-certificates' 'krb5' 'libssh2' 'libssh2.so' 'openssl' 'zlib'
+ 'libpsl' 'libpsl.so' 'libnghttp2' 'libidn2' 'libidn2.so' 'zstd')
+provides=('libcurl.so' curl)
+conflicts=(curl)
+source=("git+https://github.com/curl/curl")
+sha512sums=('SKIP')
build() {
cd curl
- ./buildconf
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
--disable-ldap \
--disable-ldaps \
- --enable-ipv6 \
- --enable-manual \
+ --disable-manual \
+ --disable-ipv6 \
--enable-versioned-symbols \
--enable-threaded-resolver \
--with-gssapi \
+ --with-libssh2 \
--with-random=/dev/urandom \
--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
@@ -45,6 +43,8 @@ package() {
cd curl
make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install -C scripts
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ # license
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
}