summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2015-06-13 21:29:49 +0200
committerMuflone2015-06-13 21:29:49 +0200
commit0a4045b707f1a9d3d46d1c708d6e9ce3237f7d27 (patch)
tree610b0a2be379e1db52b4ddbcd34c6d668cb4be79 /PKGBUILD
parentadc450cc4b0804f15183df36b4028fcf543b3b14 (diff)
downloadaur-0a4045b707f1a9d3d46d1c708d6e9ce3237f7d27.tar.gz
Updated package cuttlefish-bzr 76-6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 12 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b27418e52bbd..ab3dd13f4ead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,40 @@
-# Maintainer: Muflone <webreg@vbsimple.net>
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: Ryon Sherman <ryon.sherman@gmail.com>
pkgname=cuttlefish-bzr
-_pkgname=cuttlefish
pkgver=76
-pkgrel=5
+pkgrel=6
pkgdesc="Adapt your computer's appearance and settings according to the environment."
arch=('any')
url="https://launchpad.net/cuttlefish"
license=('GPL')
-depends=('python2' 'python2-distutils-extra' 'python2-psutil' 'python2-udev' 'gnome-menus' 'libwnck3')
+depends=('python2-distutils-extra' 'python2-psutil' 'python2-udev' 'python2-dbus' 'python2-xdg' 'gnome-menus' 'libwnck3')
makedepends=('bzr')
+conflicts=('cuttlefish')
install="${pkgname}.install"
-source=("${_pkgname}"::"bzr+https://code.launchpad.net/~noneed4anick/cuttlefish/trunk"
+source=("${pkgname}"::"bzr+https://code.launchpad.net/~noneed4anick/cuttlefish/trunk"
"plugins-use-site-packages.patch"
"desktop-autostart.patch"
- )
-md5sums=('SKIP'
- '7c631a9a83197b4d2ae5274d53b5ec73'
- 'b555d227e909a61788a4d2c8acd3120d')
-sha1sums=('SKIP'
- '43cd8935b8db879fb383164358d0dcd1d59cfd69'
- '3498c050110cb84fe36706c627ac232652afb4b3')
+ "remove-ubuntu_almost_fixed_height_mode.patch")
sha256sums=('SKIP'
'e7cf831a5083655a29a765626a765fe44069b05c31f5749ca76f6d9f22160480'
- '26a91ab2ff6c21f8f3e8eb3474396ec8940313f158778b1fd8711f2643357a5d')
+ '26a91ab2ff6c21f8f3e8eb3474396ec8940313f158778b1fd8711f2643357a5d'
+ '30d17a770792016d07c9a695376bddca17c201143b2e2e04aa30f3b83d90905b')
pkgver() {
- cd "${_pkgname}"
+ cd "${pkgname}"
bzr revno
}
prepare() {
- cd "${_pkgname}"
+ cd "${pkgname}"
patch -p1 -i "../plugins-use-site-packages.patch"
patch -p1 -i "../desktop-autostart.patch"
+ patch -p1 -i "../remove-ubuntu_almost_fixed_height_mode.patch"
}
package() {
- cd "${_pkgname}"
+ cd "${pkgname}"
glib-compile-schemas "data/glib-2.0/schemas"
GSETTINGS_SCHEMA_DIR="data/glib-2.0/schemas" python2 setup.py install --root="${pkgdir}/" --optimize=1
}