summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrealgagu2018-03-15 13:36:26 -0500
committerfrealgagu2018-03-15 13:36:26 -0500
commita290c22efd1ceff3f6fd498f2220e6f28f6ee1e3 (patch)
tree2f1a8f6f38327a841fba4ec650f626fbfa8c3c55 /PKGBUILD
parentc9ebd0fd3bb5026d7b3d31cea0549fefe72972b2 (diff)
downloadaur-a290c22efd1ceff3f6fd498f2220e6f28f6ee1e3.tar.gz
Upgrading to version svn_history
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7635ad6365c..a0c526d61291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 271927 2017-12-02 20:55:03Z dvzrv $
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
# Maintainer: David Runge <dave@sleepmap.de>
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: Ray Rashif <schiv@archlinux.org>
@@ -9,42 +9,43 @@
# 2012/03/21: <dropped from community; broken + see bug #28344>
pkgname=cwiid
-pkgver=0.6.00+svn201
-pkgrel=3
+pkgver=svn_history
+pkgrel=1
pkgdesc="Linux Nintendo Wiimote interface"
arch=('x86_64')
-url="http://abstrakraft.org/cwiid"
+url="http://abstrakraft.org/${pkgname}"
depends=('bluez-libs' 'gtk2' 'python2')
license=('GPL')
-install="$pkgname.install"
-source=("https://github.com/abstrakraft/cwiid/archive/svn_history.tar.gz")
+install="${pkgname}.install"
+source=("https://github.com/abstrakraft/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('25c105c37ae0778b6e47c4a02bfc74380f3b3dcc4cb71a3968a243a7de33c55d8b6d7860d826d1d5a6a197223fdb6022effd27d40394ca7007d997694438739b')
+#cwiid-0.6.00 trunk@201 svn_history
+
prepare() {
- cd "${pkgname}-svn_history"
+ cd "${pkgname}-${pkgver}"
# fixing ldconfig use in configure
sed -i '/ldconfig/s/WITH/ENABLE/' configure.ac
autoreconf -fi
}
build() {
- cd "${pkgname}-svn_history"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-python=python2 \
- --enable-ldconfig=no
-
- LDFLAGS+=" -pthread -lpthread -lbluetooth" \
- make
+ cd "${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-python=python2 \
+ --enable-ldconfig=no
+
+ LDFLAGS+=" -pthread -lpthread -lbluetooth" make
}
package() {
- cd "${pkgname}-svn_history"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
# wminput README
- install -Dm644 wminput/README \
- "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
+ install -Dm644 wminput/README "${pkgdir}/usr/share/doc/${pkgname}/wminput/README"
}
# vim:set ts=2 sw=2 et: