summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Platte2015-06-18 03:42:26 +0200
committerJonas Platte2015-06-18 03:42:26 +0200
commitdeae82c275fba7ad200e6ad197c00169f8637104 (patch)
tree1e222e1200c0d8c00e4f3c9ac7416dba94530245 /PKGBUILD
downloadaur-deae82c275fba7ad200e6ad197c00169f8637104.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72631fa7dfaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jonas Platte <aur@jonasplatte.de>
+
+pkgname=cxxtools-git
+pkgver=2.2.2.8ee2899
+pkgrel=1
+pkgdesc="A modular, multithreaded, high performance webapplication server for C++"
+arch=('i686' 'x86_64')
+url="http://www.tntnet.org/cxxtools"
+license=('LGPL')
+depends=('gcc-libs' 'sh')
+makedepends=('git')
+provides=('cxxtools')
+conflicts=('cxxtools')
+source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+# This will very likely break if cxxtools starts using tags. That is intentional,
+# as the --always will be removed then anyway, requiring an update
+pkgver() {
+ cd "$pkgname"
+ echo "2.2.2.$(git describe --always)"
+}
+
+build() {
+ cd "$pkgname"
+
+ autoreconf -i
+ ./configure --enable-silent-rules --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname"
+
+ ./test/alltests
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}