summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGavin lyons2016-12-10 01:51:43 +0000
committerGavin lyons2016-12-10 01:51:43 +0000
commit4f1d8942472ec5b06c543a80f1098ae9cefc1a65 (patch)
tree67db5d298ada1ca4de38b9c3ba4d1bf5ada4ae20 /PKGBUILD
parentfd42ced4d92526b1c44ca75d83e8cc2296f8dd6a (diff)
downloadaur-4f1d8942472ec5b06c543a80f1098ae9cefc1a65.tar.gz
version 3.0-1 see changelog.md details
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38d65062e8a7..b7ca8f0fdb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=2.3
-pkgrel=2
+pkgver=3.0
+pkgrel=1
pkgdesc="Updates, Maintenance, backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
@@ -11,6 +11,7 @@ optdepends=(
'cower: AUR package for AUR work'
'gdrive: AUR package for google drive backup'
'lostfiles: AUR package for finding lost files'
+ 'pacaur: AUR helper'
'rmlint: Finds lint and other unwanted'
'rkhunter: finds root kits malware'
'clamav: used for finding malware'
@@ -18,12 +19,18 @@ optdepends=(
'gnu-netcat: used for checking network'
'ccrypt: used for encrypting'
'rsync: used for backup'
+ 'inxi: system information viewer'
+ 'htop: interactive process viewer'
+ 'wavemon: wireless network monitor'
+ 'speedtest-cli: internet bandwidth'
+ 'lynis: system audit tool'
+
)
source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
-md5sums=('b3a4977ddd244dc41c3d1105b9736f7f')
+md5sums=('53233eeb97e9982176e4269ad3a1df2f')
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname}"
install -D -m644 Readme.md "$pkgdir/usr/share/doc/${pkgname}/Readme.md"
install -D -m644 changelog.md "$pkgdir/usr/share/doc/${pkgname}/changelog.md"