summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Alexander Steffens2019-08-08 08:44:59 +0000
committerJan Alexander Steffens2019-08-08 08:44:59 +0000
commit8579f2e7a7bb490bc93fa63b518b51b61e936d19 (patch)
tree5109b71d4a3f81b26fb635aa9b6c7eb2e91b21c9 /PKGBUILD
parent1d0ad350e2e65bf10904e2161fb39679481e1045 (diff)
downloadaur-8579f2e7a7bb490bc93fa63b518b51b61e936d19.tar.gz
0.3.15-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57d05f916107..bf07aaa50bba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
pkgname=d-feet
-pkgver=0.3.14
+pkgver=0.3.15
pkgrel=1
pkgdesc="D-Bus debugger for GNOME"
arch=('any')
url="https://wiki.gnome.org/Apps/DFeet"
license=('GPL2')
depends=('gtk3' 'python-gobject')
-makedepends=('intltool' 'itstool' 'gobject-introspection')
+makedepends=('gobject-introspection' 'meson' 'python-pycodestyle' 'yelp-tools')
+checkdepends=('xorg-server-xvfb')
source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
-sha256sums=('eedc20a97e7eee4cce9348a19565db8f5e0947abbf74e34f0711ca4279e414d5')
+sha256sums=('1fff149ad01ccbd93c927f5733346a9122324b9d367da3adbf4f1a52e47dfdb1')
-build() {
+prepare() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-tests
- make
+}
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ ninja -C build
}
check() {
- cd $pkgname-$pkgver
- make check
+ xvfb-run meson test -C build --print-errorlogs
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
+ python -m compileall -d /usr/lib "$pkgdir/usr/lib"
+ python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
}