summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVojtech Horky2019-11-18 09:15:01 +0100
committerVojtech Horky2019-11-18 09:15:01 +0100
commit48463432fc99fe4170e2b1a9e73c63386b488e6e (patch)
treeabf06617a9a1cf5ddbe82dc71438f5e3f5fc4502 /PKGBUILD
downloadaur-48463432fc99fe4170e2b1a9e73c63386b488e6e.tar.gz
Initial upload: d3s-nagios-plugins-git r9.9865cf3-1
Initial upload: d3s-nagios-plugins-git r9.9865cf3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecb005b21ad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Vojtech Horky <github.com/vhotspur>
+
+pkgname=d3s-nagios-plugins-git
+_reponame="d3s-nagios-plugins"
+pkgver=r9.9865cf3
+pkgrel=1
+pkgdesc="A collection of various mini-plugins for Nagios."
+arch=('any')
+license=('Apache')
+url="https://github.com/D-iii-S/d3s-nagios-plugins"
+# Most AUR helpers unfortunately do not support versioned deps in the AUR ("python-acme=${pkgver}")
+depends=('python')
+makedepends=('git')
+source=("${_reponame}"::"git+https://github.com/D-iii-S/${_reponame}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_reponame}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_reponame}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}