summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Broda2018-03-02 19:39:31 +0100
committerRobin Broda2018-03-02 19:39:31 +0100
commit424a18088a8f65f84e40a64796ce835c9fcec561 (patch)
tree0f2b34b7882ebb03207fafa53916ddb1dc28a5f6 /PKGBUILD
parente92265bdc201164cd6574c9885acfead73bccd8f (diff)
downloadaur-424a18088a8f65f84e40a64796ce835c9fcec561.tar.gz
Add patches to honor CFLAGS & LDFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3de3f67e4608..815b34ceccfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,25 @@
pkgname=daemontools-encore
pkgver=1.10
-pkgrel=2
+pkgrel=3
pkgdesc="collection of tools for managing UNIX services - derived from the public-domain release of daemontools by D. J. Bernstein."
arch=('i686' 'x86_64')
url="https://untroubled.org/daemontools-encore"
license=('MIT')
depends=('sh')
-source=("https://untroubled.org/daemontools-encore/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9f48f3c6cdd3f2b0202532e87f9ff46ea86777ca31ebda3a96bed618104bbd31')
+source=("https://untroubled.org/daemontools-encore/${pkgname}-${pkgver}.tar.gz"
+ 'ldflags.patch'
+ 'cflags.patch')
+sha256sums=('9f48f3c6cdd3f2b0202532e87f9ff46ea86777ca31ebda3a96bed618104bbd31'
+ '3842bbef9690295e77faab723205361667415f9788de6e09150f02e6a006c423'
+ 'b61e21071c1f115d32dd36f58f826310981e17978f5542e15da071abaf6fe22a')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch conf-cc "${srcdir}/cflags.patch"
+ patch conf-ld "${srcdir}/ldflags.patch"
+}
build() {
cd "${pkgname}-${pkgver}"