aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames2021-02-02 08:08:51 +0000
committerJames2021-02-02 08:08:51 +0000
commit101d64978d9255f55b0c5bee09be0146f04e2785 (patch)
tree665b4f0aa3e2da5dce20f8db0b1013ab8767c640 /PKGBUILD
parentdbc7a23e3a3501ff78c0aa62d7de15171f8238f4 (diff)
downloadaur-101d64978d9255f55b0c5bee09be0146f04e2785.tar.gz
Updated install script to handle usecase where data directory exists in fs but does not have all the expected game files
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70403861736e..6c421ef90f20 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -142,8 +142,12 @@ package() {
#Then loop through package file listing and copy files into the package directory
for SRC_FILE in `cat ${srcdir}/data-files.txt`
do
- DST_FILE=${pkgdir}/$(echo $SRC_FILE)
- cp $SRC_FILE $DST_FILE
+ DST_FILE=${pkgdir}/$(echo $SRC_FILE)
+ if [ -f $SRC_FILE ]; then
+ cp $SRC_FILE $DST_FILE
+ else
+ echo "$SRC_FILE not found. Skipping inclusion in package."
+ fi
done
fi
unzip -q "${srcdir}/engine.zip" -d "${pkgdir}/${DEST_DIR}/${ENGINE_DIR}"