summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Baudisch2018-06-17 12:14:13 +0200
committerJan Baudisch2018-06-17 12:14:13 +0200
commit4ababccb550070776e922bb6f0dd0029cb902229 (patch)
tree6e0c466f2d1d1950d6cf9c9210f0e1f083d4ca19 /PKGBUILD
downloadaur-dallas-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db6b4f479fed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+pkgname=dallas-git
+pkgver=1460109
+pkgrel=1
+pkgdesc="TI-BASIC compiler written in Go"
+arch=("x86_64")
+url="https://github.com/Mitchell-Riley/dallas"
+license=("unknown")
+makedepends=("go")
+provides=("dallas")
+conflicts=("dallas")
+source=("$pkgname::git+https://github.com/Mitchell-Riley/dallas.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git rev-parse --short HEAD
+}
+
+prepare() {
+ cd "$pkgname"
+ mkdir -p "src/github.com/Mitchell-Riley/dallas"
+ mv main.go compiler src/github.com/Mitchell-Riley/dallas/
+}
+
+build() {
+ cd "$pkgname"
+ export GOPATH=$(pwd)
+ cd "src/github.com/Mitchell-Riley/dallas"
+ go build main.go
+}
+
+package() {
+ install -Ddm755 "$pkgdir/usr/bin"
+ install -m755 "$pkgname/src/github.com/Mitchell-Riley/dallas/main" "$pkgdir/usr/bin/dallas"
+}