summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2018-01-12 17:22:00 +0100
committerJosip Ponjavic2018-01-12 17:22:00 +0100
commitc19f6ffc8d8a1ff95a0489ac9934e00b9255549b (patch)
treec294d934dfd935d5cab35aee8c7c8de9ed0e636b /PKGBUILD
parent96cda248f4352a499c0179bb303904117b72182d (diff)
downloadaur-damadamas-icon-theme-git.tar.gz
bump...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f3cb52d24ab..c6d1529973f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=damadamas-icon-theme-git
-pkgver=0.2.r11.g40e706c
+pkgver=0.7.r0.g02d288d
pkgrel=1
pkgdesc="DamaDamas icons aim to offer a familiar interface to the users"
url="https://github.com/sonakinci41/DamaDamas-icon-theme"
arch=('any')
license=('GPL3')
depends=('gtk-update-icon-cache')
-makedepends=('git')
+makedepends=('git' 'python' 'rsync')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!strip')
-source=("git+${url}.git")
+source=("${pkgname%-*}::git+${url}.git")
md5sums=("SKIP")
pkgver() {
- cd DamaDamas-icon-theme
+ cd "${pkgname%-*}"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+build() {
+ cd "${pkgname%-*}"
+ sed -e 's|os.path.expanduser("~")+"/.icons"|"./build"|' -i damadamas-installer.py
+ python damadamas-installer.py
+}
+
package() {
- rm -r DamaDamas-icon-theme/{.git,LICENSE,*.md,*.py,*.txt}
+ cd "${pkgname%-*}"/build
install -d "$pkgdir/usr/share/icons"
- cp -a DamaDamas-icon-theme "$pkgdir/usr/share/icons/"
+ cp -a DamaDamas-icon-theme "$pkgdir/usr/share/icons/DamaDamas"
}