summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Knopf2018-11-03 11:23:52 -0400
committerPaul Knopf2018-11-03 11:23:52 -0400
commiteceaa6a9dbb0806865b3da3b7ad2aec363633d52 (patch)
treef075c67a2a43eb7c106fb0467f450555fdfb03fc /PKGBUILD
parent3940136b4b4687c02b906e329c291a54be45f07f (diff)
downloadaur-eceaa6a9dbb0806865b3da3b7ad2aec363633d52.tar.gz
Auto update from to 0.25.0.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec8cc7189478..146dc3ce4796 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Paul Knopf <pauldotknopf@gmail.com>
pkgname=darch
-pkgver=0.21.0
+pkgver=0.25.0
pkgrel=1
epoch=
pkgdesc="A utility to that uses containerd to build stateless operating system images that can be booted bare-metal."
@@ -8,22 +8,20 @@ arch=('x86_64')
url="https://github.com/godarch/darch"
license=('MIT')
groups=()
-depends=('libseccomp')
+depends=('libseccomp', 'containerd')
makedepends=()
checkdepends=()
optdepends=()
-provides=('containerd' 'runc')
-conflicts=('containerd' 'runc')
replaces=()
backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver.tar.gz::https://github.com/godarch/darch/releases/download/v$pkgver/darch-amd64-with-runtime.tar.gz")
-md5sums=('08ccd7bb10938f0150a205bdc44d1779')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/godarch/darch/archive/v$pkgver.tar.gz")
+md5sums=('79e8f497d8e761e15245290b040a4dcc')
noextract=()
validpgpkeys=()
package() {
# The tarball has all the directories setup correctly.
- cp * -r $pkgdir
+ make install DESTDIR=$pkgdir
}