summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2019-12-22 15:33:06 -0800
committerMike Swanson2019-12-22 15:33:06 -0800
commit57bbb66bf646035cdeba38ff2db6ead81fb4cd89 (patch)
tree0c5ab4a97d3a33f75ca5477c45c5d6118ed4d987 /PKGBUILD
parentb8adb5c0b809394ab1e39459f642664826ee31e9 (diff)
downloadaur-57bbb66bf646035cdeba38ff2db6ead81fb4cd89.tar.gz
Remove obsolete dependencies, add zlib, allow parallel build again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 22 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3085ab98a2eb..2f563b921770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,47 +4,45 @@
pkgname=darkplaces
pkgver=20140513
-pkgrel=2
+pkgrel=3
pkgdesc="An advanced Quake 1 game engine"
arch=('i686' 'x86_64')
url="http://icculus.org/twilight/darkplaces/"
license=('GPL2')
-depends=('alsa-lib' 'hicolor-icon-theme' 'libjpeg-turbo' 'libxpm' 'libxxf86vm' 'sdl')
-makedepends=('xextproto' 'xf86dgaproto' 'xf86vidmodeproto' 'xproto')
+depends=('alsa-lib' 'hicolor-icon-theme' 'libjpeg-turbo' 'libxpm'
+ 'libxxf86vm' 'sdl' 'zlib')
install=$pkgname.install
source=(http://icculus.org/twilight/$pkgname/files/darkplacesengine$pkgver.zip
$pkgname.desktop)
-sha256sums=('69e5a50991884196e403bd6aab4a33bba553a934a167be366672ab4e223b06c9'
- '476f513f85da873ce93c89f2078bf9c2ea244e3e13a19c6ab02e818ddf221c37')
+sha512sums=('45864b590057c6de0ea978b3cc967feb879b87b2d376f3b4d8525e037b10ca1fc68599c152506494bb06669c6c2304e0aa0ee1b28f7a0d589d10c23f7285052c'
+ 'daed32cb397b8f5d8a569b0679680377b9a1fb7a30fc5b99742381723850b792424d221deafb48ed4bad99d9fc7812f8a667263d9f0e63a40fbc2d9e1013c1d6')
noextract=(darkplacesengine$pkgver.zip)
prepare() {
- cd "$srcdir"
- bsdtar -xf darkplacesengine$pkgver.zip darkplacesenginesource$pkgver.zip
- bsdtar -xf darkplacesenginesource$pkgver.zip
- cd "$pkgname"
-
- # Fix a couple options in the Makefile.
- sed -i '1i DP_LINK_TO_LIBJPEG=1' makefile
- sed -i '/(STRIP)/d' makefile.inc
+ cd "$srcdir"
+ bsdtar -xf darkplacesengine$pkgver.zip darkplacesenginesource$pkgver.zip
+ bsdtar -xf darkplacesenginesource$pkgver.zip
+ cd "$pkgname"
+
+ # Fix a couple options in the Makefile.
+ sed -i '1i DP_LINK_TO_LIBJPEG=1' makefile
+ sed -i '/(STRIP)/d' makefile.inc
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname"
- # Make sure Darkplaces is not compiled with -j > 1.
- MAKEFLAGS="${MAKEFLAGS} -j1"
- make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake release
+ make OPTIM_RELEASE="${CFLAGS}" DP_FS_BASEDIR=/usr/share/games/quake release
}
package() {
- cd $srcdir/$pkgname
- install -d $pkgdir/usr/bin
- install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
+ cd $srcdir/$pkgname
+ install -d $pkgdir/usr/bin
+ install -m755 darkplaces-{dedicated,glx,sdl} $pkgdir/usr/bin
- for i in 16 24 32 48 64 72; do
- install -Dm644 darkplaces${i}x${i}.png $pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/darkplaces.png
- done
+ for i in 16 24 32 48 64 72; do
+ install -Dm644 darkplaces${i}x${i}.png $pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/darkplaces.png
+ done
- install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}