summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsaez0pub2017-10-15 19:45:04 +0200
committersaez0pub2017-10-15 19:45:04 +0200
commitb9a0975e1c2c3e7a5f1de30c0b2deca8f32d8b4f (patch)
treef418cde4a39dfc198b2b7705a5fdffa03e79767f /PKGBUILD
downloadaur-b9a0975e1c2c3e7a5f1de30c0b2deca8f32d8b4f.tar.gz
first version on aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0ef5b29451f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: IanDury
+
+pkgname=dashticz-git
+pkgver=2.r3127
+pkgrel=1
+pkgdesc="Alternative dashboard for Domoticz"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/robgeerts/dashticz_v2/tree/master"
+#license=('GPL') ?
+depends=('domoticz')
+install='dashticz.install'
+makepends=('coreutils')
+source=("git+https://github.com/robgeerts/dashticz_v2.git"
+ 'dashticz.install')
+sha256sums=('SKIP'
+ 'a87b3c6299d9e33fc985d76c2ba6034f15a3cc5221b0379d758c00fffe0a16d4')
+_gitname="dashticz_v2"
+
+pkgver() {
+ cd $_gitname
+ echo -e "$pkgver\c" | sed -e 's/\..*//'
+ echo ".r"$(git log | wc -l)
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/domoticz/www/dashboard"
+ cp -r $_gitname/* "${pkgdir}/opt/domoticz/www/dashboard/"
+ chown -R http:http "${pkgdir}/opt/domoticz/www"
+}