summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEnzzo Cavallo2020-02-27 12:20:50 -0300
committerEnzzo Cavallo2020-02-27 12:20:50 -0300
commit06eac7ede88388a4ef7b6b433fff820031eee2ab (patch)
tree3a9beb3258176a021bd1a0697bcbf25bcb678dcf /PKGBUILD
parent9d542886d34cb8551f603d08080c3db7c7b3729f (diff)
downloadaur-06eac7ede88388a4ef7b6b433fff820031eee2ab.tar.gz
Fix deps, remove echo debug, and use of _ standard in PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbd39877e265..aead69319aaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Enzzo Cavallo <souenzzo at gmail dot com>
pkgname=datomic-cli
pkgver=0.10.81
-pkgrel=0
+pkgrel=1
pkgdesc="Command line tools for datomic cloud"
arch=('any')
url="https://docs.datomic.com/cloud/releases.html"
license=('custom')
-depends=('java-environment' 'clojure')
-makedepends=('unzip')
-bins=('datomic' 'datomic-access' 'datomic-analytics' 'datomic-gateway')
+depends=('aws-cli' 'clojure')
+_bins=('datomic' 'datomic-access' 'datomic-analytics' 'datomic-gateway')
source=("https://datomic-releases-1fc2183a.s3.amazonaws.com/tools/$pkgname/$pkgname-$pkgver.zip")
md5sums=('67dee58f92dfd2bb494076cf4f85fb4b')
package() {
- echo $srcdir
- for bin in "${bins[@]}"; do
+ for bin in "${_bins[@]}"; do
install -Dm755 "$srcdir/$pkgname/$bin" "$pkgdir/usr/bin/$bin"
done
}