summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYorick Rommers2015-08-05 13:44:16 +0200
committerYorick Rommers2015-08-05 13:44:16 +0200
commit77676fbdf197e28319fe839ef16517b30e7e5732 (patch)
treeb2e716c4b561a718c0c5e4b72cc49b8fcb145a48 /PKGBUILD
downloadaur-77676fbdf197e28319fe839ef16517b30e7e5732.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8a63101bd00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yorick Rommers <yorick-rommers@hotmail.com>
+
+pkgname=dattobd
+pkgver=20150805
+pkgrel=1
+pkgdesc="kernel module for taking block-level snapshots and incremental backups of Linux block devices"
+arch=('any')
+url="https://github.com/datto/dattobd"
+license=('unknown')
+depends=('')
+source=("git://github.com/datto/dattobd.git"
+ "http://www.imegumii.nl/dattobd.conf")
+md5sums=("SKIP"
+ "SKIP")
+build() {
+ cd "$srcdir/$pkgname"
+ sudo make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ sudo make install
+ sudo install -D "src/dattobd.ko" "/usr/lib/modules//$(uname -r)/"
+ sudo install -D "../dattobd.conf" "/etc/modules-load.d/"
+ sudo modprobe dattobd
+}
+