summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2020-07-03 01:09:06 +0200
committerPellegrino Prevete2020-07-03 01:09:06 +0200
commita18ce375a2f4ace08f8fe0b306fe695fc79cd271 (patch)
tree2e866f3681e318eab4c4ccb84bee8be32a5cbe2d /PKGBUILD
parentffdef3e57925ea4373c46fcfff9ddd62ace6338a (diff)
downloadaur-a18ce375a2f4ace08f8fe0b306fe695fc79cd271.tar.gz
better pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97a67d1148b6..f42c7657c928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
-pkgname=daty-git
+_pkgname=daty
+pkgname=$_pkgname-git
pkgver=0.1
pkgrel=1
pkgdesc='Daty Wikidata Editor'
-url='https://gitlab.com/tallero/daty'
+url='https://gitlab.gnome.org/World/daty'
license=('AGPLv3')
arch=('any')
depends=('libhandy' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
makedepends=('python-setuptools')
-provides=('daty')
-conflicts=('daty')
+provides=($_pkgname)
+conflicts=($_pkgname)
source=('daty::git+https://gitlab.gnome.org/World/Daty.git')
sha256sums=('SKIP')
package() {
- cd "daty"
+ cd "${_pkgname}"
python3 setup.py install --root="${pkgdir}" --optimize=1
}