summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex2021-05-19 19:10:10 +0200
committerAlex2021-05-19 19:10:10 +0200
commit78bf0b62d3088966fb8625da059bc27dca791a78 (patch)
tree61ca7b2340a71152f76078d634519686422d22d5 /PKGBUILD
parent7854015812c823b86cd8b5bcbed85428108946d6 (diff)
downloadaur-78bf0b62d3088966fb8625da059bc27dca791a78.tar.gz
fix permission issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 37 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59c811c56a06..6692491e055a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,19 +12,19 @@ _referid='0431af121c6242c3b3a08f8846d16eac'
_siteurl="https://www.blackmagicdesign.com/api/register/us/download/${_downloadid}"
_useragent="User-Agent: Mozilla/5.0 (X11; Linux ${CARCH}) \
- AppleWebKit/537.36 (KHTML, like Gecko) \
- Chrome/77.0.3865.75 \
- Safari/537.36"
+ AppleWebKit/537.36 (KHTML, like Gecko) \
+ Chrome/77.0.3865.75 \
+ Safari/537.36"
_reqjson="{ \
- \"firstname\": \"Arch\", \
- \"lastname\": \"Linux\", \
- \"email\": \"someone@archlinux.org\", \
- \"phone\": \"202-555-0194\", \
- \"country\": \"us\", \
- \"state\": \"New York\", \
- \"city\": \"AUR\", \
- \"product\": \"DaVinci Resolve\" \
+ \"firstname\": \"Arch\", \
+ \"lastname\": \"Linux\", \
+ \"email\": \"someone@archlinux.org\", \
+ \"phone\": \"202-555-0194\", \
+ \"country\": \"us\", \
+ \"state\": \"New York\", \
+ \"city\": \"AUR\", \
+ \"product\": \"DaVinci Resolve\" \
}"
_reqjson="$( printf '%s' "$_reqjson" | sed 's/[[:space:]]\+/ /g')"
@@ -32,31 +32,31 @@ _useragent="$(printf '%s' "$_useragent" | sed 's/[[:space:]]\+/ /g')"
_useragent_escaped="${_useragent// /\\ }"
_srcurl="$(curl \
- -s \
- -H 'Host: www.blackmagicdesign.com' \
- -H 'Accept: application/json, text/plain, */*' \
- -H 'Origin: https://www.blackmagicdesign.com' \
- -H "$_useragent" \
- -H 'Content-Type: application/json;charset=UTF-8' \
- -H "Referer: https://www.blackmagicdesign.com/support/download/${_referid}/Linux" \
- -H 'Accept-Encoding: gzip, deflate, br' \
- -H 'Accept-Language: en-US,en;q=0.9' \
- -H 'Authority: www.blackmagicdesign.com' \
- -H 'Cookie: _ga=GA1.2.1849503966.1518103294; _gid=GA1.2.953840595.1518103294' \
- --data-ascii "$_reqjson" \
- --compressed \
- "$_siteurl")"
+ -s \
+ -H 'Host: www.blackmagicdesign.com' \
+ -H 'Accept: application/json, text/plain, */*' \
+ -H 'Origin: https://www.blackmagicdesign.com' \
+ -H "$_useragent" \
+ -H 'Content-Type: application/json;charset=UTF-8' \
+ -H "Referer: https://www.blackmagicdesign.com/support/download/${_referid}/Linux" \
+ -H 'Accept-Encoding: gzip, deflate, br' \
+ -H 'Accept-Language: en-US,en;q=0.9' \
+ -H 'Authority: www.blackmagicdesign.com' \
+ -H 'Cookie: _ga=GA1.2.1849503966.1518103294; _gid=GA1.2.953840595.1518103294' \
+ --data-ascii "$_reqjson" \
+ --compressed \
+ "$_siteurl")"
DLAGENTS=("https::/usr/bin/curl \
- -gqb '' -C - --retry 3 --retry-delay 3 \
- -H Host:\ sw.blackmagicdesign.com \
- -H Upgrade-Insecure-Requests:\ 1 \
- -H ${_useragent_escaped} \
- -H Accept:\ text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8 \
- -H Accept-Language:\ en-US,en;q=0.9 \
- -o %o \
- --compressed \
- %u")
+ -gqb '' -C - --retry 3 --retry-delay 3 \
+ -H Host:\ sw.blackmagicdesign.com \
+ -H Upgrade-Insecure-Requests:\ 1 \
+ -H ${_useragent_escaped} \
+ -H Accept:\ text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8 \
+ -H Accept-Language:\ en-US,en;q=0.9 \
+ -o %o \
+ --compressed \
+ %u")
pkgname=davinci-resolve
@@ -68,7 +68,7 @@ arch=('any')
url="https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion"
license=('Commercial')
depends=('glu' 'gtk2' 'gstreamer' 'libpng12' 'lib32-libpng12' 'ocl-icd' 'openssl-1.0' 'fuse2'
- 'opencl-driver' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
+ 'opencl-driver' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
makedepends=('libarchive' 'xdg-user-dirs')
options=('!strip')
provides=('davinci-resolve')
@@ -96,9 +96,8 @@ source=("${_archive}"::"$_srcurl")
prepare()
{
# Remove udev rules (The official installer does not remove these files. This leads to the conflict "exists in the file system".)
- confiles=$(find /usr/lib/udev/rules.d -name 75-davincipanel.rules -o -name 75-sdx.rules 2> /dev/null | awk -F/ '{print $NF}'
- find /opt/resolve/configs -name log-conf.xml -o -name config.dat 2> /dev/null | awk -F/ '{print $NF}'
- )
+ confiles=$( find /usr/lib/udev/rules.d -name 75-davincipanel.rules -o -name 75-sdx.rules 2> /dev/null | awk -F/ '{print $NF}'
+ find /opt/resolve/configs -name log-conf.xml -o -name config.dat 2> /dev/null | awk -F/ '{print $NF}')
if [ "${confiles}" ]; then
echo -e "\033[1m==> The file(s) $(echo ${confiles} | xargs | sed 's/ /, /g') already exist in your filesystem.\033[0m"
echo -e "\033[1m==> This can lead to a conflict and the installation will fail.\033[0m"