summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex2020-10-12 22:55:45 +0200
committerAlex2020-10-12 22:55:45 +0200
commit76bda8b55fe2f515123579ed08f97e66f0aeec80 (patch)
treeb89d5b2331740401715e8f2adc5eb40891c6ff0d /PKGBUILD
parentec2747a69c04eae38d15fab5b77881d68f43723e (diff)
downloadaur-76bda8b55fe2f515123579ed08f97e66f0aeec80.tar.gz
Update to v16.3b3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 61 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59139b7e8a57..002ec05aa784 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,70 @@
# Maintainer: Alex S. <shantanna_at_hotmail_dot_com>
# Contributor: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
-# You'll need to download the package archive from
-# https://www.blackmagicdesign.com/support/
-
# Hardware support is limited. Nvidia cards should work fine.
# If you're running a hybrid setup, try with primusrun/optirun.
+# This was originally written by Daniel Bermond in blackmagic-decklink-sdk pkgbuild
+# It is sufficient to just replace _downloadid to correspond new release version
+# It can be obtained from chromium -> Developer Tools -> Network -> XHR -> click latest-version and copy downloadId
+_downloadid='c9aa06affcc246ab8535c709888c7ef9' # dr 16.1b3
+_referid='71f39d0c920b4322b09ae2456623bee4'
+_siteurl="https://www.blackmagicdesign.com/api/register/us/download/${_downloadid}"
+
+_useragent="User-Agent: Mozilla/5.0 (X11; Linux ${CARCH}) \
+ AppleWebKit/537.36 (KHTML, like Gecko) \
+ Chrome/77.0.3865.75 \
+ Safari/537.36"
+
+_reqjson="{ \
+ \"platform\": \"Linux\", \
+ \"country\": \"us\", \
+ \"firstname\": \"Arch\", \
+ \"lastname\": \"Linux\", \
+ \"email\": \"someone@archlinux.org\", \
+ \"phone\": \"202-555-0194\", \
+ \"state\": \"New York\", \
+ \"city\": \"AUR\", \
+ \"hasAgreedToTerms\": true, \
+ \"product\": \"Desktop Video ${pkgver} SDK\" \
+}"
+
+_reqjson="$( printf '%s' "$_reqjson" | sed 's/[[:space:]]\+/ /g')"
+_useragent="$(printf '%s' "$_useragent" | sed 's/[[:space:]]\+/ /g')"
+_useragent_escaped="${_useragent// /\\ }"
+
+_srcurl="$(curl \
+ -s \
+ -H 'Host: www.blackmagicdesign.com' \
+ -H 'Accept: application/json, text/plain, */*' \
+ -H 'Origin: https://www.blackmagicdesign.com' \
+ -H "$_useragent" \
+ -H 'Content-Type: application/json;charset=UTF-8' \
+ -H "Referer: https://www.blackmagicdesign.com/support/download/${_referid}/Linux" \
+ -H 'Accept-Encoding: gzip, deflate, br' \
+ -H 'Accept-Language: en-US,en;q=0.9' \
+ -H 'Authority: www.blackmagicdesign.com' \
+ -H 'Cookie: _ga=GA1.2.1849503966.1518103294; _gid=GA1.2.953840595.1518103294' \
+ --data-ascii "$_reqjson" \
+ --compressed \
+ "$_siteurl")"
+
+DLAGENTS=("https::/usr/bin/curl \
+ -gqb '' -C - --retry 3 --retry-delay 3 \
+ -H Host:\ sw.blackmagicdesign.com \
+ -H Upgrade-Insecure-Requests:\ 1 \
+ -H ${_useragent_escaped} \
+ -H Accept:\ text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8 \
+ -H Accept-Language:\ en-US,en;q=0.9 \
+ -o %o \
+ --compressed \
+ %u")
+
+
pkgname=davinci-resolve-studio-beta
_pkgname=resolve
resolve_app_name=com.blackmagicdesign.resolve
-pkgver=16.1b3
+pkgver=16.3b3
pkgrel=1
arch=('any')
url="https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion"
@@ -26,35 +80,20 @@ if [ ${pkgname} == "davinci-resolve-studio-beta" ]; then
# Variables for STUDIO edition
pkgdesc='Professional A/V post-production software suite from Blackmagic Design. Studio edition, requires license key or license dongle.'
_archive_name=DaVinci_Resolve_Studio_${pkgver}_Linux
- sha256sums=('ca59f7cc4f704a46a8451fbb3110e846292d1a77b15965d6c5e03f2688dc7a05')
+ sha256sums=('85c46b57c5f91c9ad2edff5aaaf864fb3f5fa2fb665845ded9536f415599010e')
conflicts=('davinci-resolve-beta' 'davinci-resolve' 'davinci-resolve-studio')
else
# Variables for FREE edition
pkgdesc='Professional A/V post-production software suite from Blackmagic Design'
_archive_name=DaVinci_Resolve_${pkgver}_Linux
- sha256sums=('af6b84176a5aeb66432452e038f540b86d13cdec82d91e648338bd0a585e0d06')
+ sha256sums=('eb81a0f4e0f327187dea8c3449bf6d1a210d0fd50ce836b42cb58e65e097c2ad')
conflicts=('davinci-resolve' 'davinci-resolve-studio' 'davinci-resolve-studio-beta')
fi
_archive=${_archive_name}.zip
_installer_binary=${_archive_name}.run
-# Trying to make the user's life easier ;o)
-msg2 "Trying to fetch the archive file if available..."
-DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
-
-if [ ! -f ${PWD}/${_archive} ]; then
- if [ -f $DOWNLOADS_DIR/${_archive} ]; then
- ln -sfn $DOWNLOADS_DIR/${_archive} ${PWD}
- else
- msg2 ""
- msg2 "The package can be downloaded here: https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion"
- msg2 "Please remember to put a downloaded package ${_archive}into the build directory ${PWD} or $DOWNLOADS_DIR"
- msg2 ""
- fi
-fi
-
-source=("local://${_archive}")
+source=("${_archive}"::"$_srcurl")
prepare()
{