summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNieDzejkob2018-08-17 14:07:41 +0200
committerNieDzejkob2018-08-17 14:07:41 +0200
commit1553f18d5d36c9e467eacdaa406003aa48c47aa8 (patch)
tree2112c81e12b804da76fec48e4dc633fdeaf25f9f /PKGBUILD
downloadaur-1553f18d5d36c9e467eacdaa406003aa48c47aa8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..840fb9ff3618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jakub Kądziołka <kuba@kadziolka.net>
+
+pkgname=dazzlie-git
+pkgver=31.facd1c9
+pkgrel=1
+pkgdesc="a command-line program that lets you convert between various retro tile graphics formats and PNG"
+arch=(x86_64)
+url="https://github.com/obskyr/dazzlie"
+license=(MIT)
+depends=(gc pcre libevent)
+makedepends=(crystal git)
+source=(git+ssh://git@github.com/obskyr/dazzlie.git)
+sha1sums=(SKIP)
+
+pkgver(){
+ cd dazzlie
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare(){
+ sed -i 's/crystal deps/shards/;s/crystal build/\0 --link-flags -Wl,-z,relro,-z,now,--as-needed/' dazzlie/Makefile
+}
+
+build(){
+ cd dazzlie
+ make
+}
+
+package(){
+ cd dazzlie
+ install -Dm755 bin/dazzlie "$pkgdir/usr/bin/dazzlie"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/dazzlie-git/LICENSE"
+}