summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit8ff91d611cf1e0fcaa620055258ea7eac4d67aef (patch)
tree181a669ec64e6888366cd4b8c330e7db64064210 /PKGBUILD
downloadaur-8ff91d611cf1e0fcaa620055258ea7eac4d67aef.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7c0ef5766f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Xilon <xilonmu@gmail.com>
+pkgname=dbhub
+pkgver=0.451
+pkgrel=1
+pkgdesc='Direct Connect hub software, based on Open DC Hub but with many enhancements.'
+arch=('i686' 'x86_64')
+url='http://www.dbhub.org'
+license=('GPL')
+depends=('libcap' 'openssl')
+makedepends=('perl')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tbz2")
+md5sums=('79cf321b521b548dabfccdb57500a8f0')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i 's/^\(ACLOCAL=.*\)-${am__api_version}\(.*\)$/\1\2/' configure
+ sed -i 's/^\(AUTOMAKE=.*\)-${am__api_version}\(.*\)$/\1\2/' configure
+
+ ./configure --prefix=/usr --enable-switch-user --enable-perl \
+ CFLAGS="$CFLAGS" || return 1
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+