summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Buch Hansen2019-10-18 09:44:36 +0200
committerDaniel Buch Hansen2019-10-18 09:44:36 +0200
commit4d6ec6e1bc0081c471ffdba0f0c99b2891593389 (patch)
tree07ea8455ad493cd7e6c2703a53e8b9f0313ab822 /PKGBUILD
downloadaur-4d6ec6e1bc0081c471ffdba0f0c99b2891593389.tar.gz
initial skel for package submission
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60efba20fade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Buch Hansen (dbuch) <boogiewasthere@gmail.com>
+
+pkgname=dbuch-zsh-config
+pkgver=1
+pkgrel=1
+pkgdesc="dbuch zsh configuration"
+url="https://github.com/dbuch/"
+arch=(x86_64)
+license=(GNU General Public License v3.0)
+depends=(zsh exa bat skim)
+makedepends=(git)
+source=("git+https://github.com/dbuch/dbuch-zsh-config.git")
+conflicts=('grml-zsh-config')
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+
+ git submodule init
+
+ git config --local submodule.subprojects/zsh-async.url "$srcdir/zsh-async"
+
+ git submodule update
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ install -D -m644 zshrc.skel \
+ ${pkgdir}/etc/skel/zshrc
+
+ install -D -m644 zshrc \
+ ${pkgdir}/etc/zsh/zshrc
+
+ install -D -m644 zsh-async/async.zsh \
+ ${pkgdir}/usr/share/zsh/functions/Async/async
+
+ install -D -m644 dbuch-prompt.zsh \
+ ${pkgdir}/usr/share/zsh/functions/Prompts/prompt_dbuch_setup
+}
+
+# vim:set sw=2 et: